Study your flashcards anywhere!

Download the official Cram app for free >

  • Shuffle
    Toggle On
    Toggle Off
  • Alphabetize
    Toggle On
    Toggle Off
  • Front First
    Toggle On
    Toggle Off
  • Both Sides
    Toggle On
    Toggle Off
  • Read
    Toggle On
    Toggle Off
Reading...
Front

How to study your flashcards.

Right/Left arrow keys: Navigate between flashcards.right arrow keyleft arrow key

Up/Down arrow keys: Flip the card between the front and back.down keyup key

H key: Show hint (3rd side).h key

A key: Read text to speech.a key

image

Play button

image

Play button

image

Progress

1/12

Click to flip

12 Cards in this Set

  • Front
  • Back
What configuration steps are required to configure vPV between identical NX-OS switches (5 bullets)?
-Enable vPC.
-Define the vPC domain.
-Establish peer keepalive connectivity.
-Create a peer link.
-Create a vPC.
What commands would you use to achieve the following:

-Enable vPC and set the vPC domain to 10.
-Verify the above.

feature vpc
vpc domain 10



show vpc role - last 2 Hex characters of "vPC system-mac" will equal vPC Domain ID.

What commands would you use to achieve the following:



-Configure the vPC Peer-Keepalive link for vPC Domain 10.
-Use the 192.168.1.0/24 subnet.
-Ensure best practice is followed.
-Verify and explain how to determine that the link is up.

vpc domain 10
peer-keepalive destination 192.168.1.2 source 192.168.1.1 vrf VPC-KEEPALIVE



show vpc peer-keepalive - "vPC keep-alive status" should be "alive"

Configure the vPC Peer-Link based on the following requirements:



-Traffic must be load-balanced across Eth1/1-2.
-VLAN's 100-105 must be permitted across the link.
-VLAN 100 must be native.
-Ensure STP knows what type of interface this is.

feature lacp
interface eth 1/1-2
switchport
channel-group 20 mode active
!
interface port-channel 20
switchport mode trunk
switchport trunk allowed vlan 100-105
switchport trunk native vlan 100
vpc peer-link
spanning-tree port type network

Configure the vPC Member Port on N7K-1 based on the following requirements:



-Use multiple physical interfaces (Eth 1/3-4) for added redundancy.
-Use a sensible naming convention.

interface eth 1/3-4
channel-group 101 mode active
interface port-channel 101
switchport mode trunk
vpc 101
State the benefits of the "Peer-Switch" command (3 bullets) and apply it to vPC Domain 10.

-This will reduce traffic loss when there is a restoration of the Peer-Link.
-This will reduce disruption associated with dual-active failure.
-This will reduce the impact of lost BPDU's during an STP reconvergence.



vpc domain 10
peer-switch

If the "Peer-Switch" command wasn't applied, explain how STP works with vPC and how issues may occur (3 bullets).
-The vPC Primary Peer transmits BPDU's on the vPC links, the Peer Link and any orphan ports.
-The vPC Secondary Peer does not transmit BPDU's on the vPC links.
-If the Secondary Peer becomes STP Root, there would be a reconvergence if this switch was lost, which would result in packets loss.
Explain how the "Peer-Switch" command overcomes potential STP issues.
-Both Peer Switches send BPDU's on the vPC links using the vPC System MAC as the STP bridge ID i.e. they appear as a single switch.
If the vPC Peer-Link fails, but the Peer-Keepalive Link is still operational, how will traffic on the Secondary Peer be affected (2 bullets).
-All vPC ports will be suspended.
-Orphan ports remain operational.
Describe how the vPC Check Rule may create an issue when FHRP's are deployed.
-Some NAS/Servers using certain NIC teaming techniques may not use an ARP request when responding to client request and may just use the SVI MAC of the switch that forwarded the request.
-The vPC load-balancing algorithm may send this traffic to the wrong switch, which will then traverse the Peer Link to the correct switch.
-If the outbound port is also a vPC, the packet will be dropped.
Configure the vPC domain to prevent the issues associated with the vPC Check Rule dropping traffic when FHRP's are used. Explain how this will resolve the issue and how to verify (2 bullets).

vpc domain 10
peer-gateway



-Normally each HSRP peer would be able to forward traffic directed to its own SVI MAC and the HSRP virtual MAC. This command will allow each HSRP peer to forward traffic directed to the SVI MAC of the other peer.
-This can be verified using the "show mac address table vlan xxx" command on both peers, each Gateway MAC will be highlighted with a "G".

What is the "go-to" command for verifying vPC configuration?
show vpc brief